Need Application up...
 
Notifications
Clear all

Need Application update for X2

Abhi0702
(@abhi0702)
New Member

Hi, I have a X2, but recently most of the apps are not working. I am getting error that this app is not compatible with this device.

Netflix, hotstar, YouTube.

Nothing is working. Please help in getting the correct applications

Quote
Topic starter Posted : 23/12/2021 3:40 pm
r4ulb4rr4g4n
(@r4ulb4rr4g4n)
Active Member

ocupo el Stock Firmware AUN X2 android 7.1.2 alguien me lo pasa porfavor?

ReplyQuote
Posted : 24/12/2021 7:01 am